Blog

File Under Not Supported (PowerShell and Clustering Content)

By: on November 16, 2009 in Failover Clustering, PowerShell, Windows Server 2008, Windows Server 2008 R2

So it’s no secret I’ve been using Windows Server 2008 R2 for quite some time. I like the PowerShell commandlets, and I’ve occasionally used the failover clustering module for PowerShell in R2 to manage “downlevel” Windows Server 2008 RTM (and SP2) based clusters with no issue.

This week I also figured, “What the heck?” and installed PowerShell 2.0 on a Windows Server 2008 SP2 cluster, and took the module from R2. It seemed to work just fine. You obviously don’t get any new features, so things like Live Migration won’t work. Only the basic failover clustering PowerShell commands would technically be applicable.

Despite both of these scenarios seemingly working fine in my limited use of them, they are 100% unsupported by Microsoft. So I will say this: I’m glad I tried it, but I would never recommend you doing something that would put your supportability in jeopardy – especially on a production system. If you do use these in either of the scenarios, do it at your own risk.


Leave a Reply